NETWORK ENGINEER BLOG

Tips and Reviews for Engineers

Cisco と NetApp(7-Mode)で LAG 設定

以前、Nexus と Netapp 間で LAG を構成する際の注意点の記事で LAG の設定例を書きましたが、NetAppのソフトウェアバージョン8.2では、少し設定が異なったのでメモします。
それぞれ2本のインターフェースで LAG を構成し、NetApp 側は VLAN101と102のインターフェースを作成します。Cisco 側は VLAN101と VLAN102を透過する設定例になります。

Cisco の設定

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 101,102
 switchport mode trunk
 channel-group 1 mode on
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 101,102
 switchport mode trunk
 channel-group 1 mode on

NetApp の設定

ifgrp create multi ifgrp0 -b ip e0a e0b
vlan create ifgrp0 101 102
ifconfig ifgrp0-101 192.168.101.100 netmask 255.255.255.0 partner ifgrp0
ifconfig ifgrp0-102 192.168.102.100 netmask 255.255.255.0 partner ifgrp0
ifgrp status
default: transmit 'IP Load balancing', Ifgrp Type 'multi_mode', fail 'log'
ifgrp0: 2 links, transmit 'IP Load balancing', Ifgrp Type 'multi_mode' fail 'default'
         Ifgrp Status   Up      Addr_set
        up:
        e0a: state up, since 02Apr2016 13:18:54 (01:04:47)
                mediatype: auto-1000t-fd-up
                flags: enabled
                input packets 2408902, input bytes 3601548374
                output packets 1264232, output bytes 97298932
                up indications 1, broken indications 0
                drops (if) 0, drops (link) 0
                indication: up at 02Apr2016 13:18:54
                        consecutive 3887, transitions 1
        e0b: state up, since 02Apr2016 13:18:42 (01:04:59)
                mediatype: auto-1000t-fd-up
                flags: enabled
                input packets 0, input bytes 0
                output packets 122, output bytes 8396
                up indications 2, broken indications 1
                drops (if) 0, drops (link) 0
                indication: up at 02Apr2016 13:18:42
                        consecutive 4159, transitions 3