NETWORK ENGINEER BLOG

Tips and Reviews for Engineers

Fortigate の SSL-VPN を CLI で設定

FortiOS 5.6 における SSL-VPN 設定の覚書です。

ユーザ作成(user01~02を作成)

config vdom
edit "VDOM 名"
config user local
edit user01
set type password
set passwd "パスワード"
next
edit user02
set type password
set passwd "パスワード"
end

ユーザグループ作成

config vdom
edit "VDOM 名"
config user group
edit "ユーザグループ名"
set member user01 user02
end

SSL-VPN ポータル作成

config vdom
edit "VDOM 名"
config vpn ssl web portal
edit "ポータル名"
set tunnel-mode enable
set web-mode enable
set ip-pools "SSLVPN_TUNNEL_ADDR1"
set split-tunneling-routing-address "宛先ネットワーク(通常 LAN 側)"
end


SSL-VPN 設定

config vdom
edit "VDOM 名"
config vpn ssl settings
set servercert "Fortinet_Factory"
set tunnel-ip-pools "SSLVPN_TUNNEL_ADDR1"
set source-interface "SSL-VPN インターフェース(通常 WAN 側)"
set source-address "all"
set default-portal "web-access"
config authentication-rule
edit 1
set groups "ユーザグループ名"
set portal "ポータル名"
end
end


IPv4 ポリシー設定

config vdom
edit "VDOM 名"
config firewall policy
edit 2
set name "ポリシー名"
set srcintf "SSL-VPN トンネルインターフェース"
set dstintf "出力インターフェース(通常 LAN 側)"
set srcaddr "all"
set dstaddr "宛先ネットワーク(通常 LAN 側)"
set action accept
set schedule "always"
set service "ALL"
set groups "ユーザグループ名"
set ssl-ssh-profile "certificate-inspection"
set nat enable
end

SSL-VPN モニタ

get vpn ssl monitor