NETWORK ENGINEER BLOG

Tips and Reviews for Engineers

Cisco ルータの PPPoE 設定例

Cisco ルータの PPPoE 設定例です。
フレッツに接続する際の注意点として、Dialer インターフェースの MRU があります。
Cisco ではデフォルトで MRU が 1500 となっており、フレッツでは、MRU が 1454 となっています。不整合のままでも接続はできますが、PPP セッションステージで、無駄なやりとりが発生します。そのため、mtu 1454 と設定することを推奨します。
よく、サンプルに ip mtu となっているのを見かけますが、これだと MRU は変更されないため、ご注意ください。

PPPoE 設定例
hostname Router
!
interface FastEthernet1
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 !
interface Dialer1
 mtu 1454
 ip address negotiated
 encapsulation ppp
 ip tcp adjust-mss 1414
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname user-a-site1@example.com
 ppp chap password cisco
 ppp ipcp dns request
 ppp ipcp route default
!
ip nat inside source list 100 interface Dialer1 overload
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
end
PPPoE 確認
Router#show pppoe session
     1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
           SID  LocMAC                                      VA-st      Type
    N/A   1111  2222.2222.2222  Fa1                    Di1  Vi1        UP
                1111.1111.1111                              UP

参考書籍

その他参考

以上